Technical Support

eEdition DVD-ROM and CD-ROM titles

SYSTEM REQUIREMENTS
PC Information for eEdition DVD-ROMs
Windows 2000/ME/XP with DVD-ROM drive
128 MB of installed RAM

Macintosh Information for eEdition DVD-ROMs
Power PC or Intel dual-core processor with DVD-ROM drive
Mac OS 10.1.5 to 10.4.8
128 MB of available RAM

Browsers:
Internet Explorer 6 and 7 for PC; Safari 2 for Mac; For PC and Mac, use Firefox 2.

Plug-ins:
Flash Player 9
Abode Reader 6 to 8
QuickTime 7.1.3

PC Information for eEdition CD-ROMs
Windows 95/ME/2000/XP
32 MB of installed RAM

Macintosh Information for eEdition CD-ROMs
Mac OS 8.6 to 10.3.9
32 MB of available RAM

Browsers:
Internet Explorer 5.5 and 6 for PC; Internet Explorer 5 or Netscape 6.2 and higher for Mac.
DOWNLOADS
Check here for important system updates and downloads:

For the latest version of Internet Explorer for PC.
For the latest version of Firefox for PC or Mac.

eEdition DVD-ROMs utilize several plug-ins. Plug-ins are small programs that add to your browser's capabilities. Plug-ins are free, but require that you download software. You should download the following plug-ins:
Adobe Acrobat Reader
Macromedia Shockwave
Flash Player

Your school may have a policy to disable the download installation of any new plug-in software on school computers. Contact your information technology specialist to alert her about the eEdition requirements.

Frequently Asked Question



Getting Started
Do your books come with full audio versions to help the visually impaired? Some of our new DVD-ROM eEditions feature full audio versions. However, in the instances in which our eEdition books do not feature full audio versions, we have given permission to an organization called "Recording for the Blind and Dyslexic" to do so. You can find these audio versions of our books by accessing their Web site or by calling them directly at 1-866-732-3585.
Why don't the videos play in my eEdition? You must update your QuickTime plug-in to 7.1.3 or you may experience problems viewing video using a PC with Internet Explorer 6 or 7.